Katacoda CLI

The Katacoda CLI is designed to help you quickly create, manage and validate your Katacoda content.

Download v0.0.16

Pre-requisite

Katacoda CLI v2 is delivered as a node package, and to install it Node Package Manager (NPM) is required.

Npm is distributed with Node.js, which means that when you download Node.js, you automatically get NPM installed on your computer.

Download Node.js from this link, choosing the binary according to your architecture.

NPM Install

Run the following command from the terminal to install the latest CLI version.

Usage

Once installed, the CLI can be launched by running the katacoda command.

More information can be found at npmjs.com/package/katacoda-cli

Documentation

To understand more about how the CLI works, complete the following two scenarios.